Mostrar/Ocultar
Mostrar/Ocultar Foros
Mostrar/Ocultar Menú principal

Questionmark Dudas con post iconos y modo mantenimiento Compartir


Foro de Portales DragonFlyCMS, CPGNuke  Foro de Portales DragonFlyCMS, CPGNuke: Información y Soporte sobre DragonFlyCMS, antiguo CPGNuke, el CMS para construir Portales Web y que integra su propia versión de foros PhpBB, galerias de fotos, y muchas cosas mas

Ir a página Anterior  1, 2, 3  Siguiente
Foros de discusiónComunidades y Portales WebForo de Portales DragonFlyCMS, CPGNuke
Compartir enlaces Compartir enlaces

 
 
Enlace:    Corto  Largo
Copia el texto de uno de los cajones para compartir el enlace
Página 2 de 3 - Tema con 24 Mensajes y 35656 Lecturas
Último Mensaje Publicado:
Autor Mensaje
Aforo
Aforo
Junior
Junior

Registrado: Feb 18, 2008
Mensajes: 257

Envio Publicado: Vie Mar 02, 2012 2:27 am  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

fran2018 Escribio:
Aforo Escribio:
¿Le pones la opcion de global ? (abajo)

Márcala y deberia aparecer el nuevo icono en todos los foros.

Sí, lo he probado así Confundido

¿Y te aparece en la parte de administracion de iconos o tampoco?

_________________
http://www.aforo.es (La web de los foros divertidos)
Volver arriba
Ver perfil de usuario Visitar sitio web del autor
Compartir:
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Envio Publicado: Dom Mar 11, 2012 12:14 am  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

Aforo Escribio:
fran2018 Escribio:
Aforo Escribio:
¿Le pones la opcion de global ? (abajo)

Márcala y deberia aparecer el nuevo icono en todos los foros.

Sí, lo he probado así Confundido

¿Y te aparece en la parte de administracion de iconos o tampoco?

Sí, aparecen. Incluso cuando voy a iniciar un nuevo tema salen en el menú desplegable y se previsualizan en la parte derecha de dicho menú al seleccionarlos. Es al publicar el tema cuando no se visualizan en el índice de temas...
Volver arriba
Ver perfil de usuario
Compartir:
Aforo
Aforo
Junior
Junior

Registrado: Feb 18, 2008
Mensajes: 257

Envio Publicado: Lun Mar 12, 2012 11:42 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

¿"Indice de temas" te refieres al foro?

Por lo que veo funciona, puede ser que el tema (el que da color y presentación a una web) que tu hayas elegido no tenga en su plantilla lo de sacar el icono de tema.

¿Puedes poner un enlace o subir una imagen?

_________________
http://www.aforo.es (La web de los foros divertidos)
Volver arriba
Ver perfil de usuario Visitar sitio web del autor
Compartir:
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Envio Publicado: Sab Mar 17, 2012 10:59 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

Sí, Aforo, me refiero al foro. A ver si encuentro un hueco y hago unas capturas.
Volver arriba
Ver perfil de usuario
Compartir:
Aforo
Aforo
Junior
Junior

Registrado: Feb 18, 2008
Mensajes: 257

Envio Publicado: Mar Mar 20, 2012 7:20 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

O mandanos un enlace.

Muchas gracias.

_________________
http://www.aforo.es (La web de los foros divertidos)
Volver arriba
Ver perfil de usuario Visitar sitio web del autor
Compartir:
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Envio Publicado: Mie Mar 21, 2012 10:00 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

He hecho unas capturas. Es la misma explicación que he puesto en mi mensaje inicial, pero con las capturas queda mucho más claro:

Subo la imagen y...

1) La añado desde el panel de admistración en modo global. También he probado sin activar esta casilla y asignándolo a un foro en concreto pero el resultado es el mismo.


2) El posticono se ha añadido con éxito:


3) Escribo un mensaje de prueba en el foro selccionando el posticono que acabo de activar. Se previsualiza correctamente al seleccionarlo del menú desplegable:


4) Un vez enviado el mensaje, me encuentro con esto:

Volver arriba
Ver perfil de usuario
Compartir:
Aforo
Aforo
Junior
Junior

Registrado: Feb 18, 2008
Mensajes: 257

Envio Publicado: Jue Mar 22, 2012 2:56 am  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

¿tienes la url del icono de la ultima imagen?
A ver si hay algun error.

Tambien puede estar en la plantilla, como te dije.

Si pones el HTML del elemento quizas se vea mas claro el error.

_________________
http://www.aforo.es (La web de los foros divertidos)
Volver arriba
Ver perfil de usuario Visitar sitio web del autor
Compartir:
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Envio Publicado: Jue Mar 22, 2012 8:54 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

Aquí está el trozo del código fuente del documento HTML:

<td class="row1" align="center" height="34" nowrap="nowrap"><a href="index.php?name=Forums&amp;file=viewtopic&amp;t=79"><img src="themes/default/images/forums/folder_new.gif" alt="Mensajes nuevos" title="Mensajes nuevos" border="0" /></a></td>

<td class="row1" align="center" width="20"><img src="" alt="" title="" align="middle" /></td>
Volver arriba
Ver perfil de usuario
Compartir:
Aforo
Aforo
Junior
Junior

Registrado: Feb 18, 2008
Mensajes: 257

Envio Publicado: Vie Mar 23, 2012 3:24 am  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

¿te pasa ese error con la plantilla del tema por defecto? ¿el tema Default?
Un posible fallo estaria en la plantilla.

Si sigue sin salir en la plantilla blanca..

Puedes meter esta orden SQL (por ejemplo con PhpMyAdmin):

SELECT * FROM nuke_bbtopic_icons WHERE forum_id = <numero de foro> OR forum_id = -1 ORDER BY icon_name

Te deberia dar los iconos que tienes disponibles para ese foro.

<numero de foro>: hay que sustituirlo por el numero del foro.

SI eso esta bien, hay que buscar el error en:
modules/Forums/viewforum.php

_________________
http://www.aforo.es (La web de los foros divertidos)
Volver arriba
Ver perfil de usuario Visitar sitio web del autor
Compartir:
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Envio Publicado: Dom Mar 25, 2012 1:41 am  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

Aforo Escribio:
¿te pasa ese error con la plantilla del tema por defecto? ¿el tema Default?
Un posible fallo estaria en la plantilla.

Si sigue sin salir en la plantilla blanca..

Puedes meter esta orden SQL (por ejemplo con PhpMyAdmin):

SELECT * FROM nuke_bbtopic_icons WHERE forum_id = <numero de foro> OR forum_id = -1 ORDER BY icon_name

Te deberia dar los iconos que tienes disponibles para ese foro.

<numero de foro>: hay que sustituirlo por el numero del foro.

SI eso esta bien, hay que buscar el error en:
modules/Forums/viewforum.php

Sí, con el tema default.

He hecho la búsqueda (con cms_bbtopic_icons porque con nuke_bbtopic_icons me daba error) y me devuelve todos los iconos que tengo disponibles, incluído el de prueba que no se visualiza en el foro.

Pego a continuación las líneas del documento viewforum.php donde creo que se hace referencia a los posticonos. Mis conocimientos en php son muy limitados y no sé localizar el supuesto error...


# TopicIcon_mod
#grab this topic's icon_id
$topic_icon_id = $topic_rowset[$i]['icon_id'];
$topic_icon_source = '<img width="20" src="images/spacer.gif" alt="" />';
#if we have an icon
if ($topic_icon_id != NULL && $topic_icon_id != 0) {
#create the path
$topic_icon_source = '<img src="'.$topic_icons[$topic_icon_id]['icon_url'].'" alt="'.$topic_icons[$topic_icon_id]['icon_name'].'" title="'.$topic_icons[$topic_icon_id]['icon_name'].'" align="middle" />';
}
# TopicIcon_mod end

Gracias
Volver arriba
Ver perfil de usuario
Compartir:
 
Ultimo Mensaje - Publicado: 30-Mar-2012 04:15 pm
Fran2018
Fran2018
Nuevo
Nuevo

Registrado: Dic 27, 2011
Mensajes: 17

Ultimo Mensaje Publicado: Vie Mar 30, 2012 4:15 pm  Asunto: Re: Dudas con post iconos y modo mantenimiento Compartir Responder citando

Gracias por toda la ayuda, Aforo. Repasaré todo lo que me dices. Si tardo en contestar es porque últimamente tengo muy poco tiempo libre.
Volver arriba
Ver perfil de usuario
Compartir:
Mostrar mensajes de anteriores:   
Foros de discusión > Comunidades y Portales Web > Foro de Portales DragonFlyCMS, CPGNuke
 Responder al tema   Versión Imprimible Ir a página Anterior  1, 2, 3  Siguiente
Todas las horas son GMT + 1 Hora
Página 2 de 3 - Tema con 24 Mensajes y 35656 Lecturas - Última modificación: 30/03/2012




RSS: Foro de Portales DragonFlyCMS, CPGNuke RSS
Cambiar a:  


Puede publicar nuevos temas en este foro
No puede responder a temas en este foro
No puede editar sus mensajes en este foro
No puede borrar sus mensajes en este foro
No puede votar en encuestas en este foro
No Puedes adjuntar archivos en este foro
Tu puedes descargar archivos en este foro

Últimas búsquedas por posts: Hosting



Diseño web, bases de datos, lenguajes de programación, comunidades... todo lo necesario para construir tu sitio web.
The logos and trademarks used on this site are the property of their respective owners. We are not responsible for comments posted by our users, as they are the property of the poster.
Aviso Legal - Privacidad